Problem editing just-added charging location

Hi, I’m new to OCM.

I added a new charging location, (OCM-290784) and realised afterwards that I made an error as it is listed as one bay with two CC2 connectors. However it’s one charger with two bays, once connector each.

When I click edit, I just get an endless “please wait” spinning wheel. I’ve tried another browser and even using the browser on my phone with the same result. I can edit other charging locations but not this one.

Am I doing something wrong, or is it just that it needs to be approved before it can be corrected? If that’s the case it would be much more helpful to say so than give an endless “please wait”!

Thanks,

David

Hi David,

Although you can see you’re location after you have submitted we don’t currently support further edits, but that’s obviously a good idea. We only recently started showing it on the map so you can add photos or comments and edits haven’t been implemented. To edit you’d currently need to wait for the location to be approved by a country editor then submit your changes.