Cannot open specific station

This interface has not been working for a day or two. A completely blank page opens.


Hi Andy,

For me that opens up this:

Are you familiar with this like browser developer tools at all? it would be useful to see what the error message your browser is reporting (which browser is it and what version?).

Hi Christopher,

I’m using Chrome in Windows, Version 119.0.6045.160 (Official Build) (64-bit)

Here’s the browser’s error message:

main.4d54e5fa71416a11.js:1 ERROR TypeError: Cannot read properties of null (reading ‘Data’)
at Ue.initAuthFromStorage (main.4d54e5fa71416a11.js:1:273518)
at Ue.initAppManager (main.4d54e5fa71416a11.js:1:273216)
at new Ue (main.4d54e5fa71416a11.js:1:270299)
at Object.factory (main.4d54e5fa71416a11.js:1:275637)
at Pc.hydrate (main.4d54e5fa71416a11.js:1:1427061)
at Pc.get (main.4d54e5fa71416a11.js:1:1425625)
at gy.get (main.4d54e5fa71416a11.js:1:1446506)
at hi (main.4d54e5fa71416a11.js:1:1410959)
at Pi (main.4d54e5fa71416a11.js:1:1411456)
at Object.zl (main.4d54e5fa71416a11.js:1:1432338)

Here’s the URL that results in a blank.

Here’s a ‘functional’ url.

Here’s the javascript snippet that generates a blank screen in a new tab.
let url = ‘Open Charge Map - Electric Vehicle Charging Locations Near You’ + ocmId;
console.log(LS(), 'Station Edit URL: ’ + url);, ‘_blank’).focus();


Looking at our app code, that error suggests your user authentication token didn’t parse properly for some reason

I’d guess that signing out and back in again might help?

  • I’ve tried signing out and signing back in to OCM several times and it doesn’t help.
  • Signing out of OCM and then opening the link results in the same blank screen. So I’m unable to login to OCM within this tab.
  • I’ve tried removing all my passwords in Chrome and it doesn’t help.
  • It seems to work fine in Microsoft Edge
  • The this.logging.log(…) message does not appear in the chrome console.
  • Here’s a snapshot of a blank window. This is the same regardless of whether the OCM link is opened by my webpage or by dropping the link into Chrome’s address bar.

I wasn’t able to reproduce your problem but I’ve updated to the latest versions of the jwt libraries it uses and also added an additional guard for null or malformed data when reading the stored authentication information, so whatever the cause that particular error, it shouldn’t happen now. You may need to shift-reload to refresh any cached javascript etc.

Hello Christopher,
Okay, perfect. This fixes the problem in Chrome for me. I never experienced the problem on Microsoft Edge btw.
Thanks so much!

1 Like